NMT-200 ЧаВо

Баг с воспроизведением AVI

Статья WildFlexy от 30.08.2010

А точнее был замечен на AVI с сочетанием кодеков — видео MPEG4 и аудио MPEG1.

Файлы вообще невозможно проматывать! Если пользоваться для прокрутки стрелками влево-вправо (+-30 секунд), то исчезает звук. Если использовать процентное перемещение по файлу 1-9, то также или не идет звук, или старт происходит с ускоренным воспроизведением. Пауза+Play в этом случае не помогают.

Стоп+Play(или Enter) показывает, что воспроизведение началось с запомненной позиции, но реально запуск идет с 0.
Применение ускоренной перемотки также фатально сносит звук. Ускоренная перемотка выше 4x может привести к вылету в браузер.
Использование кнопки в целях выставления точной позиции по AVI также не работает.

Файл не битый:

 Video #1
Codec : XviD
Codec/Family : MPEG-4
Codec/Info : XviD project
Codec settings/PacketBitStream : No
Codec settings/BVOP : Yes
Codec settings/QPel : No
Codec settings/GMC : 0
Codec settings/Matrix : Default
PlayTime : 35mn
Bit rate : 891 Kbps
Width : 512 pixels
Height : 384 pixels
Display Aspect ratio : 4/3
Frame rate : 25.000 fps
Resolution : 8 bits
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.181
Audio #0
Codec : MPEG-1 Audio layer 3
Codec profile : Joint stereo
PlayTime : 35mn 48ms
Bit rate : 128 Kbps
Bit rate mode : CBR
Channel(s) : 2 channels
Sampling rate : 48 KHz
Resolution : 16 bits
Writing library : Xing (new)

Ну вааапще!!! Я, конечно, понимаю, что AVI в век космических кораблей — это отстой, но файлы то есть, чем же их тогда воспроизводить? Какая-то деградация прошивки явно на лицо :(
Объяснение сложностями с новым SDK как-то не вяжется с четырьмя месяцами ожидания новой прошивки.

Сдается мне, что обновляться я поторопился!

Справедливости ради, хотел добавить информацию про AVI-файл (Xvid/MPEG4+MPEG1), который воспроизводится нормально, но после его проигрывания с пробами всех видов перемоток, NMT завис при нажатии Power (переход в стендбай)… Пробовал дважды.

Следующая запись
»
2010–2017 © NMT-200 ЧаВо